GeniePoint Charger Caused High Voltage System Fault

All Jaguar I-Pace related discussions
User avatar
ianipace
Posts: 364
Joined: Sat Nov 09, 2019 9:11 pm
Location: Cardiff, UK

Re: GeniePoint Charger Caused High Voltage System Fault

Post by ianipace » Mon Jun 07, 2021 10:56 am

Ferosa, could you put the MY of your car in your signature so readers will know whether it is a MY18-20 or a new MY21. The charge ports are different.

Stay safe

Ian
MY2019 SE in Caesium Blue. Panoramic roof and now with Gloss Black 18" wheels in lieu of the 20" energy sappers! Ohme Smart charger.

slowlane
Posts: 35
Joined: Fri Oct 30, 2020 11:24 am
Location: Poole/UK

Re: GeniePoint Charger Caused High Voltage System Fault

Post by slowlane » Mon Jun 07, 2021 4:55 pm

Responding to the OP: I too was going to stay near Looe and wanted to test Geniepoint with my MY19 SE: so I tried my nearest local Geniepoint at West Moors Esso on A31. It cut out almost immediately, so no luck, but also no error.
Recently, I stayed near Great Torrington, Devon and there is one charger only in the vicinity: a 50kW CCS Geniepoint; I was very concerned but it worked first time.

In the end I never got to Looe - thwarted due to lockdown last year.
MY19SE since March 2019, Indus Silver, 18" wheels, HUD, Air, TCU 19.2, IC 21A, Zappi 1 etc.

Volkswarren
Posts: 667
Joined: Sun May 19, 2019 8:55 pm
Location: Stourbridge

Re: GeniePoint Charger Caused High Voltage System Fault

Post by Volkswarren » Mon Jun 07, 2021 8:06 pm

I used the charger in looe last year, you need an RFID card as mobile signal is not good to activate the unit via the app.
HSE, Caesium Blue, 22" 5056 Alloys, Oyster Leather, Active Air Suspension, Cold Pack, Black Pack, Privacy glass and Pano roof. Podpoint Homecharger. Telematics: 19.2 | InControl: S21A. https://share.octopus.energy/sunny-moth-32

Delta5
Posts: 568
Joined: Tue Sep 24, 2019 1:32 pm
Location: Midlands

Re: GeniePoint Charger Caused High Voltage System Fault

Post by Delta5 » Tue Jun 08, 2021 7:07 am

slowlane wrote:
Mon Jun 07, 2021 4:55 pm
Responding to the OP: I too was going to stay near Looe and wanted to test Geniepoint with my MY19 SE: so I tried my nearest local Geniepoint at West Moors Esso on A31. It cut out almost immediately, so no luck, but also no error.
Recently, I stayed near Great Torrington, Devon and there is one charger only in the vicinity: a 50kW CCS Geniepoint; I was very concerned but it worked first time.

In the end I never got to Looe - thwarted due to lockdown last year.
North Devon is well served, several good Instavolt and Polar at Bideford and Barnstaple, good to hear Genie works too
IPace SE Caesium Blue, Ivory interior, Air suspension, 18in wheels, Drivers pack, 360. arrived 16th July, very nice.

Abu Dhabi Dude
Posts: 1182
Joined: Sun Feb 02, 2020 9:34 pm
Location: United Kingdom

Re: GeniePoint Charger Caused High Voltage System Fault

Post by Abu Dhabi Dude » Sat Jun 12, 2021 1:12 pm

The only time I have ever used GeniePoint was for that video you referenced (Glasgow Airport BP garage). As seen on the video, it worked perfectly both times I used it that day (in rapid succession). I don’t think there’s a generic problem with Genie. I suspect you were just unlucky and that problem may well have happened whatever charger you plugged into that day.

SammyD
Posts: 1232
Joined: Sat Oct 13, 2018 7:44 pm
Location: N.E Hampshire, UK

Re: GeniePoint Charger Caused High Voltage System Fault

Post by SammyD » Sun Jun 13, 2021 3:38 pm

Abu Dhabi Dude wrote:
Sat Jun 12, 2021 1:12 pm
The only time I have ever used GeniePoint was for that video you referenced (Glasgow Airport BP garage). As seen on the video, it worked perfectly both times I used it that day (in rapid succession). I don’t think there’s a generic problem with Genie. I suspect you were just unlucky and that problem may well have happened whatever charger you plugged into that day.
I'm just back from a brief holiday in North West Wales. I used the Geneiepoint chargers in Bangor, Holyhead and Caernarfon all without a problem. All three connected and charged first time. They were supplying around 46kWh which is pretty good for nominally 50kWh chargers.
The only downside is the inability to get a detailed receipt of a charge session. Their site sends an email but it has zero content.

The two chargers at Morrisons in Oswestry were both out of order when I tried to use them. There were several unhappy and frustrated locals trying to get onto their support by phone when I left. I had a Plan B which was the Ecotricity charger behind the local Esso Garage. That worked first time.
Driving "Hirundo Rustica" since 15th Mar 2019. Lovely Jubbly :D :D
S20C since 11th Dec 2020 Maps : whatever is current/can be bothered to download

Post Reply