Apple Car Play Wireless Connection Adapter

All Jaguar I-Pace related discussions
NigelC
Posts: 129
Joined: Tue Nov 05, 2019 10:06 am
Location: Cornwall

Re: Apple Car Play Wireless Connection Adapter

Post by NigelC » Sun Jan 03, 2021 6:23 pm

Hi Ian,

The information you provided is incredibly helpful.

The Carplay adapter in our car seems to get to the screen where it shows on your photos "Connecting to Ian's iPhone" then it moves onto a similar screen saying autoconnecting. The carplay then eventually comes on, but it can take anywhere between 3 to 5 minutes before the Apple Car Play in the car springs into life.

Out of interest, how do you get to the screen in the car for the apple device settings?

I'm using a iPhone XS with ios 14.3. Agree, that when it works it's really quite good!

Happy New Year, and thanks for taking the time to post such a thorough message.

All the best,
Nigel
MY 20 SE Corris Grey
Delivered 09/19
H264, H270, 20C

User avatar
ianipace
Posts: 324
Joined: Sat Nov 09, 2019 9:11 pm
Location: Cardiff, UK

Re: Apple Car Play Wireless Connection Adapter

Post by ianipace » Sun Jan 03, 2021 7:04 pm

Hi Nigel, a happy new year to you and your family as well.

Getting to the Apple Car Play screen is - Touch the cogs in the home page.
Next touch General.
This then 'should' give you 'Connectivity' if my old brain has remembered correctly!
That will bring you to the photo that shows Bluetooth as the first option, which in my piccie is the one that has 'Bluetooth setting not available. etc.

Scroll down this Connectivity screen until you get to Apple Users. and touch on that
and that 'should' show the screen I've photographed!

It maybe that in your iPhone you have the Wi-Fi settings slightly different to me.
In Settings' and Wi-Fi 'Ask to Join Networks' is 'Ask'
And in case it has something to do with it 'Auto-Join Hotspot' is set to Ask to Join

The sequence it all goes through is something like this:
Ignition on, detect phone via Bluetooth, Connect
Next the dongle has its turn with Bluetooth and that connects.
Now the really clever bit happens!
Via Bluetooth the dongle is told to send WiFi to the phone and through handshaking the Bluetooth for the phone and the dongle are told to release and use WiFi instead. Wifi can transfer far more data than Bluetooth can and gives access to the car's GPS signal for Google Maps etc.
So after the handshake the car and the phone are connected via Wifi, and all your phone calls, contacts etc. are now done via Wifi.
The car knows that for Car Play this will take place over Wifi between the iPhone and car and not the USB cable!

Clever isn't it?

The answer to that is YES when it works!

I had a word with mine and told it if it didn't play ball it was going in the bin, seems to have worked!!

Stay safe

Ian
MY2019 SE in Caesium Blue. Panoramic roof and Gloss Black 18" wheels. Ohme Smart charger.

NigelC
Posts: 129
Joined: Tue Nov 05, 2019 10:06 am
Location: Cornwall

Re: Apple Car Play Wireless Connection Adapter

Post by NigelC » Tue Jan 05, 2021 10:24 am

ianipace wrote:
Sun Jan 03, 2021 7:04 pm
Hi Nigel, a happy new year to you and your family as well.

Getting to the Apple Car Play screen is - Touch the cogs in the home page.
Next touch General.
This then 'should' give you 'Connectivity' if my old brain has remembered correctly!
That will bring you to the photo that shows Bluetooth as the first option, which in my piccie is the one that has 'Bluetooth setting not available. etc.

Scroll down this Connectivity screen until you get to Apple Users. and touch on that
and that 'should' show the screen I've photographed!

It maybe that in your iPhone you have the Wi-Fi settings slightly different to me.
In Settings' and Wi-Fi 'Ask to Join Networks' is 'Ask'
And in case it has something to do with it 'Auto-Join Hotspot' is set to Ask to Join

The sequence it all goes through is something like this:
Ignition on, detect phone via Bluetooth, Connect
Next the dongle has its turn with Bluetooth and that connects.
Now the really clever bit happens!
Via Bluetooth the dongle is told to send WiFi to the phone and through handshaking the Bluetooth for the phone and the dongle are told to release and use WiFi instead. Wifi can transfer far more data than Bluetooth can and gives access to the car's GPS signal for Google Maps etc.
So after the handshake the car and the phone are connected via Wifi, and all your phone calls, contacts etc. are now done via Wifi.
The car knows that for Car Play this will take place over Wifi between the iPhone and car and not the USB cable!

Clever isn't it?

The answer to that is YES when it works!

I had a word with mine and told it if it didn't play ball it was going in the bin, seems to have worked!!

Stay safe

Ian
Hi Ian,

Tried your settings yesterday, and changed my phone so that it replicated your settings.

Connection still a bit hit and miss!

I'll send you a Private Message, with more screen photos.

Kind regards,
Nigel
MY 20 SE Corris Grey
Delivered 09/19
H264, H270, 20C

fa147
Posts: 1211
Joined: Thu Aug 08, 2019 1:25 pm
Location: London / United Kingdom

Re: Apple Car Play Wireless Connection Adapter

Post by fa147 » Sat Mar 13, 2021 2:06 pm

In case anyone is interested, ADD has done a video about CPlay2Air

I-Pace MY20 HSE, Corris Grey, Ebony/Ebony Interior, 20” Grey & Diamond Turned, Panoramic Roof
S20C1_20.48.3-635557 | Telematics: 16.2 | Map 08.030.0116.0157
Home Charging: Zappi 2.0 | I-Pace Member's Map: https://bit.ly/3cCU3Ei

golar3
Posts: 75
Joined: Wed May 20, 2020 8:33 pm
Location: Eastern Europe

Re: Apple Car Play Wireless Connection Adapter

Post by golar3 » Mon Mar 15, 2021 8:46 am

There is a dongle software update (ver. 2021.03.06.1343, size: 8.58MB).

How to install: after CarPlay initializes, make sure your phone is connected to the carplay2air’s wifi network (should be something like JAGUAR R-6 etc.) and on your phone‘s browser go to 192.168.50.2 where the update should be available.

The manufacturer detailed in a message the various available settings:

-Synchronous mode (normal, compatible):
Default: Normal mode
Normal mode: Resolve instrument panel display problems.
Compatible mode: Resolves the issue of certain vehicles not connecting to the dongle.

-Media Sound (CD, DVD):
Default: DVD
DVD: better sound quality.
CD: solves the problem of certain cars having static/playback issues.

-Media Delay (300 to 2000 milliseconds):
Default: 1000
The greater the delay, the audio is less likely to stutter. The lower the delay, the music, and album art/images will be more synchronized.

-Background mode: Some cars will go black screen after connected, so try to switch on background mode will solve it.

-GPS: Turn on this function, the adapter will then help the iPhone to obtain more accurate positioning.

About startup delay, If you set it for 5 seconds, the adapter will start the system after 5 seconds of plugging into the USB port of the car (in case some car systems do not recognize the adapter, or the adapter works only when it's replugged).
2020 Firenze Red HSE

&roid
Posts: 33
Joined: Wed Nov 13, 2019 2:07 pm
Location: Manchester, England

Re: Apple Car Play Wireless Connection Adapter

Post by &roid » Fri Mar 19, 2021 7:21 am

Saw this post so thought I’d come back to this device and try again.

Sad to say it still doesn’t work reliably :(

Really frustrating but it’s a pretty pointless as it stands
MY20 Borasco Grey HSE, black 20” wheels, contrast roof, delivered January 2020

Abu Dhabi Dude
Posts: 1128
Joined: Sun Feb 02, 2020 9:34 pm
Location: United Kingdom

Re: Apple Car Play Wireless Connection Adapter

Post by Abu Dhabi Dude » Sun Mar 21, 2021 6:51 pm

&roid wrote:
Fri Mar 19, 2021 7:21 am
Saw this post so thought I’d come back to this device and try again.

Sad to say it still doesn’t work reliably :(

Really frustrating but it’s a pretty pointless as it stands
I’d contact the company. I’ve had zero issues with mine. Works perfectly every time for me.

NigelC
Posts: 129
Joined: Tue Nov 05, 2019 10:06 am
Location: Cornwall

Re: Apple Car Play Wireless Connection Adapter

Post by NigelC » Sun Mar 21, 2021 7:59 pm

Abu Dhabi Dude wrote:
Sun Mar 21, 2021 6:51 pm
&roid wrote:
Fri Mar 19, 2021 7:21 am
Saw this post so thought I’d come back to this device and try again.

Sad to say it still doesn’t work reliably :(

Really frustrating but it’s a pretty pointless as it stands
I’d contact the company. I’ve had zero issues with mine. Works perfectly every time for me.
My Cplay2Air adapter works as follows:-

Really quick to bring up the Cplay2Air screen, the one that asks you to Click on a phone.

That screen can stay on anywhere from 1 to 5 minutes whilst Autosearching for a phone.

Sometimes pressing the Search button helps in connecting the phone.

Once the connection to the phone is made, it works great, good sound with very few stutters.

I've tried it with my wife's phone and the results are pretty much the same.

I've tried reinstalling firmware as per the download file link early on in this thread, and my phone says that the Cplay2Air unit is running the latest software (March 2021).

I sent an email to the company asking for a returns authorisation, but never got a response.

Whether the unit will eventually "autoconnect" with my front offside tyre remains to be seen!

So all in all its not been a great experience, but it kind of works. &roid, you are not alone.

Regards,
Nigel
MY 20 SE Corris Grey
Delivered 09/19
H264, H270, 20C

Abu Dhabi Dude
Posts: 1128
Joined: Sun Feb 02, 2020 9:34 pm
Location: United Kingdom

Re: Apple Car Play Wireless Connection Adapter

Post by Abu Dhabi Dude » Sun Mar 21, 2021 9:22 pm

Sounds like there may be a few quality control issues. Maybe like my Ecotricity charging I’ve been lucky again! Mine really has been impeccable. Can take up to a minute to connect (usually less than 30 seconds) and when that screen you mention comes up (the connect to phone one) it auto connects within a few seconds with no interaction from me. So it definitely sounds like there are a few faulty dongles out there. Sorry to hear company’s comms haven’t been great for you. That doesn’t help.

NigelC
Posts: 129
Joined: Tue Nov 05, 2019 10:06 am
Location: Cornwall

Re: Apple Car Play Wireless Connection Adapter

Post by NigelC » Mon Mar 22, 2021 3:21 pm

Abu Dhabi Dude wrote:
Sun Mar 21, 2021 9:22 pm
Sounds like there may be a few quality control issues. Maybe like my Ecotricity charging I’ve been lucky again! Mine really has been impeccable. Can take up to a minute to connect (usually less than 30 seconds) and when that screen you mention comes up (the connect to phone one) it auto connects within a few seconds with no interaction from me. So it definitely sounds like there are a few faulty dongles out there. Sorry to hear company’s comms haven’t been great for you. That doesn’t help.
Hi ADD,

That's where I got to - put it down to a dodgy unit. Usually it isn't an issue and usually connects in its own sweet time - but on the rare occasions when it doesn't connect it's very distracting trying to press different things on the screen whilst looking at the road.

There is one advantage though - when we set off, the auto connect screen is generally up and running and we're just waiting for Car Play to spring into action, you realise just how whisper quiet the I-Pace is!

On balance it's no big deal - you just get used to it. I'm hoping that another software revision might fix it.

All the best,
Kind regards,
Nigel
MY 20 SE Corris Grey
Delivered 09/19
H264, H270, 20C

Post Reply