Google Pixel 5 won't connect to Android Auto

All Jaguar I-Pace related discussions
electric beagle
Posts: 185
Joined: Fri Jul 17, 2020 9:23 pm
Location: United Kingdom

Google Pixel 5 won't connect to Android Auto

Post by electric beagle » Sun Oct 18, 2020 1:26 pm

Not sure if this is an Android 11 related issue but my new phone will not launch Android Auto at all, the car detects it but then nothing happens.

Worked fine on my Pixel 3 XL running Android 10.

Anyone else had this issue with either the pixel.oe Android 11?
MY21HSE, Portofino Blue, Oyster interior, Wireless Charger, Cupholder Covers, Active Air Suspension, Adaptive Dynamics, Clear Sight rear view mirror, Panoramic Roof, Privacy Glass, Upgraded Cabin Lighting, Aluminium trim, Andersen EV Charger

BrendonSF
Posts: 49
Joined: Sun Aug 19, 2018 4:17 pm
Location: San Francisco

Re: Google Pixel 5 won't connect to Android Auto

Post by BrendonSF » Sun Oct 18, 2020 3:50 pm

Assuming you're trying wired, the first thing I'd try is a new cable; preferably OEM. Because you're on the pivi pro system, you're in a bit of rare company I'm afraid.
2020 I-PACE SE

electric beagle
Posts: 185
Joined: Fri Jul 17, 2020 9:23 pm
Location: United Kingdom

Re: Google Pixel 5 won't connect to Android Auto

Post by electric beagle » Sun Oct 18, 2020 4:33 pm

BrendonSF wrote:
Sun Oct 18, 2020 3:50 pm
Assuming you're trying wired, the first thing I'd try is a new cable; preferably OEM. Because you're on the pivi pro system, you're in a bit of rare company I'm afraid.
The cable works I had my pixel 3 connected to it. Tried switching to my new Pixel 5 today and it just doesn't seem to have been recognised for Android Auto, so have reverted back to the old phone for the time being.
MY21HSE, Portofino Blue, Oyster interior, Wireless Charger, Cupholder Covers, Active Air Suspension, Adaptive Dynamics, Clear Sight rear view mirror, Panoramic Roof, Privacy Glass, Upgraded Cabin Lighting, Aluminium trim, Andersen EV Charger

Abu Dhabi Dude
Posts: 997
Joined: Sun Feb 02, 2020 9:34 pm
Location: United Kingdom

Re: Google Pixel 5 won't connect to Android Auto

Post by Abu Dhabi Dude » Sun Oct 18, 2020 5:12 pm

I know that some android phones don’t actually support android auto. I don’t use android but I did get one just to try out WattCat and it doesn’t have android auto built in. I believe it’s something to do with the OS being “Android Go” or something. Like I said, I’m no android expert but that’s as far as I got. As I didn’t care, I didn’t pursue it.

User avatar
Koala
Posts: 169
Joined: Sun Mar 17, 2019 8:40 pm
Location: Germany - Bavaria

Re: Google Pixel 5 won't connect to Android Auto

Post by Koala » Sun Oct 18, 2020 6:48 pm

electric beagle wrote:
Sun Oct 18, 2020 1:26 pm
Not sure if this is an Android 11 related issue but my new phone will not launch Android Auto at all, the car detects it but then nothing happens.

Worked fine on my Pixel 3 XL running Android 10.

Anyone else had this issue with either the pixel.oe Android 11?
I did a short test with the Pixel 2 XL of my wife after the upgrade to Android 11. It has worked fine. However: The "Android Auto" app needs to be installed on the phone. The Android Auto app is not a default part of Android 11. The installation was done automatically when connected to the car, I only had to agree to the installation on the phone. Maybe you double check for the Android Auto app on your phone. Or load it from the playstore.
https://play.google.com/store/apps/deta ... n.gearhead
EV400 S, MY2019, Firenze Red, Light Oyster Interieur, Acitve Air suspension, 18" Diamond turned Wheels.
Infotainment-Software: S20B1_20.30.2-578440| Telematics: 17.2 | 45.000 KM of happy I-Pace driving since March 14th, 2019

electric beagle
Posts: 185
Joined: Fri Jul 17, 2020 9:23 pm
Location: United Kingdom

Re: Google Pixel 5 won't connect to Android Auto

Post by electric beagle » Sun Oct 18, 2020 7:16 pm

Koala wrote:
Sun Oct 18, 2020 6:48 pm
electric beagle wrote:
Sun Oct 18, 2020 1:26 pm
Not sure if this is an Android 11 related issue but my new phone will not launch Android Auto at all, the car detects it but then nothing happens.

Worked fine on my Pixel 3 XL running Android 10.

Anyone else had this issue with either the pixel.oe Android 11?
I did a short test with the Pixel 2 XL of my wife after the upgrade to Android 11. It has worked fine. However: The "Android Auto" app needs to be installed on the phone. The Android Auto app is not a default part of Android 11. The installation was done automatically when connected to the car, I only had to agree to the installation on the phone. Maybe you double check for the Android Auto app on your phone. Or load it from the playstore.
https://play.google.com/store/apps/deta ... n.gearhead
I am very familiar with Android and in moving from Pixel 3 to Pixel 5 the pre-existing apps capable of being added (all but those with security exceptions such as work Apps) add to the new phone, this included Android Auto which now has new setup options for wireless operation. The Pixel 5 only became available at the end of last week so it is a brand new to market phone, although Android 11 makes most capable phones wireless Android Auto compatible.

Android Auto is very much installed and working on the new phone. It works fine with my Pixel 3XL, it launches in standalone mode on the Pixel 5 but when plugged into the car the message "follow actions on the phone screen" appears on the car display) and nothing appears on the phone.

I had problems with the Pixel 3 in the wife's car when I first got it too so perhaps some Android Auto updates may be forthcoming in the near future which should resolve it. For now I have gone back to the old phone.

My attempts to connect either phone wirelessly came to nothing. The car doesn't seem to recognise the potential to connect wirelessly, despite what I was led to believe when ordering the car.
MY21HSE, Portofino Blue, Oyster interior, Wireless Charger, Cupholder Covers, Active Air Suspension, Adaptive Dynamics, Clear Sight rear view mirror, Panoramic Roof, Privacy Glass, Upgraded Cabin Lighting, Aluminium trim, Andersen EV Charger

ardevd
Posts: 1130
Joined: Mon Dec 24, 2018 12:30 am
Location: Norway

Re: Google Pixel 5 won't connect to Android Auto

Post by ardevd » Mon Oct 19, 2020 8:48 am

I assume you're running Android 11 on the 3 XL as well? I suspect there might be an issue with your Pixel 5. It's not necessarily faulty but it might be a bug in the Bluetooth or USB stack somewhere. If possible, try it with a nother Pixel 5. If it still doesn't work, report the issue to Google's Android Auto team (they are quite responsive on the bug tracker) and see what they say.
Control your I-Pace with jlrpy or WattCat for Android| I-PACE HSE Ebny Prem Txt MY2019.

Telematics: 18.2 | InControl: S20B_20.27.3-568398

electric beagle
Posts: 185
Joined: Fri Jul 17, 2020 9:23 pm
Location: United Kingdom

Re: Google Pixel 5 won't connect to Android Auto

Post by electric beagle » Mon Oct 19, 2020 9:17 am

ardevd wrote:
Mon Oct 19, 2020 8:48 am
I assume you're running Android 11 on the 3 XL as well? I suspect there might be an issue with your Pixel 5. It's not necessarily faulty but it might be a bug in the Bluetooth or USB stack somewhere. If possible, try it with a nother Pixel 5. If it still doesn't work, report the issue to Google's Android Auto team (they are quite responsive on the bug tracker) and see what they say.
No I deliberately kept Android 10 on the 3XL as I suspected there might be oddities.

I may try switching wireless Android Auto off on the 5 and see if that resolves things, in case that is in some way interfering.
MY21HSE, Portofino Blue, Oyster interior, Wireless Charger, Cupholder Covers, Active Air Suspension, Adaptive Dynamics, Clear Sight rear view mirror, Panoramic Roof, Privacy Glass, Upgraded Cabin Lighting, Aluminium trim, Andersen EV Charger

ardevd
Posts: 1130
Joined: Mon Dec 24, 2018 12:30 am
Location: Norway

Re: Google Pixel 5 won't connect to Android Auto

Post by ardevd » Mon Oct 19, 2020 9:26 am

electric beagle wrote:
Mon Oct 19, 2020 9:17 am
ardevd wrote:
Mon Oct 19, 2020 8:48 am
I assume you're running Android 11 on the 3 XL as well? I suspect there might be an issue with your Pixel 5. It's not necessarily faulty but it might be a bug in the Bluetooth or USB stack somewhere. If possible, try it with a nother Pixel 5. If it still doesn't work, report the issue to Google's Android Auto team (they are quite responsive on the bug tracker) and see what they say.
No I deliberately kept Android 10 on the 3XL as I suspected there might be oddities.

I may try switching wireless Android Auto off on the 5 and see if that resolves things, in case that is in some way interfering.
Alternatively, upgrade your Pixel 3XL to Android 11 and see if you have issues. There have been plenty of reports of Android 11 related issues with AA.
Control your I-Pace with jlrpy or WattCat for Android| I-PACE HSE Ebny Prem Txt MY2019.

Telematics: 18.2 | InControl: S20B_20.27.3-568398

electric beagle
Posts: 185
Joined: Fri Jul 17, 2020 9:23 pm
Location: United Kingdom

Re: Google Pixel 5 won't connect to Android Auto

Post by electric beagle » Mon Oct 19, 2020 9:29 am

ardevd wrote:
Mon Oct 19, 2020 9:26 am
electric beagle wrote:
Mon Oct 19, 2020 9:17 am
ardevd wrote:
Mon Oct 19, 2020 8:48 am
I assume you're running Android 11 on the 3 XL as well? I suspect there might be an issue with your Pixel 5. It's not necessarily faulty but it might be a bug in the Bluetooth or USB stack somewhere. If possible, try it with a nother Pixel 5. If it still doesn't work, report the issue to Google's Android Auto team (they are quite responsive on the bug tracker) and see what they say.
No I deliberately kept Android 10 on the 3XL as I suspected there might be oddities.

I may try switching wireless Android Auto off on the 5 and see if that resolves things, in case that is in some way interfering.
Alternatively, upgrade your Pixel 3XL to Android 11 and see if you have issues. There have been plenty of reports of Android 11 related issues with AA.
Yes I have had this before where new versions of Android do not sit nicely with AA, I don't particularly want to upgrade my one phone that works with AA in the car until I know I won't break that too.

Generally an AA update comes along and fixes any problems after a few weeks.
MY21HSE, Portofino Blue, Oyster interior, Wireless Charger, Cupholder Covers, Active Air Suspension, Adaptive Dynamics, Clear Sight rear view mirror, Panoramic Roof, Privacy Glass, Upgraded Cabin Lighting, Aluminium trim, Andersen EV Charger

Post Reply