S20A_20.07.5-507626 SOTA

All Jaguar I-Pace related discussions
scm
Posts: 944
Joined: Fri Jan 18, 2019 1:11 pm
Location: Southampton

Re: S20A_20.07.5-507626 SOTA

Post by scm » Fri May 15, 2020 3:34 pm

Real programmers use things like "%d" for integers and "%s" for strings, for example. ;)

SammyD
Posts: 1064
Joined: Sat Oct 13, 2018 7:44 pm
Location: N.E Hampshire, UK

Re: S20A_20.07.5-507626 SOTA

Post by SammyD » Fri May 15, 2020 4:16 pm

scm wrote:
Fri May 15, 2020 3:34 pm
Real programmers use things like "%d" for integers and "%s" for strings, for example. ;)
Nah... they use F14.4 for floating point numbers.
(or would you prefer COBOL?)
Driving "Hirundo Rustica" since 15th Mar 2019. Lovely Jubbly :D :D
S20A_20.07.5-507626 Maps : whatever is current.

Abu Dhabi Dude
Posts: 439
Joined: Sun Feb 02, 2020 9:34 pm
Location: United Kingdom

Re: S20A_20.07.5-507626 SOTA

Post by Abu Dhabi Dude » Fri May 15, 2020 4:58 pm

dernotte wrote:
Fri May 15, 2020 3:20 pm

Usually in the computer world, when you see a %1 in a screen, this means.... a substitution bug. When you design a screen, especially if you need to localize that screen in different language, or you have have to display some dynamic value (as opposed to static text) , you will use some kind of placeholder in your screen template definition, and then at the very last moment, when you need to display the screen, you will substitute every placeholder with the correct string or value. "%1" is a standard placeholder, which means the first placeholder in the screen. In this case, I guess, JLR wanted to display "Infotainment-Software:", and then the version number of it (the dynamic value). There is probably a bug , and the system was not able to replace the "%1" by the version number of it.
That makes sense. Mine doesn’t have that “%1” part.

elbocko
Posts: 494
Joined: Sat Mar 09, 2019 3:49 pm
Location: Fareham, Hampshire

Re: S20A_20.07.5-507626 SOTA

Post by elbocko » Fri May 15, 2020 7:51 pm

SammyD wrote:
Fri May 15, 2020 4:16 pm
scm wrote:
Fri May 15, 2020 3:34 pm
Real programmers use things like "%d" for integers and "%s" for strings, for example. ;)
Nah... they use F14.4 for floating point numbers.
(or would you prefer COBOL?)
Macro-11 in Octal, please.
El Bocko

E 2ERO, SE, Firenze Red, MY19, 18". Still loving it.
Infotainment - S20C_20.16.5-536345.
Vehicle Connectivity 17.2,
Battery Energy Control Shh, it won't say. H264v3 completed.

User avatar
Koala
Posts: 76
Joined: Sun Mar 17, 2019 8:40 pm
Location: Germany - Bavaria

Re: S20A_20.07.5-507626 SOTA

Post by Koala » Fri May 15, 2020 7:56 pm

Abu Dhabi Dude wrote:
Fri May 15, 2020 4:58 pm
dernotte wrote:
Fri May 15, 2020 3:20 pm

Usually in the computer world, when you see a %1 in a screen, this means.... a substitution bug. When you design a screen, especially if you need to localize that screen in different language, or you have have to display some dynamic value (as opposed to static text) , you will use some kind of placeholder in your screen template definition, and then at the very last moment, when you need to display the screen, you will substitute every placeholder with the correct string or value. "%1" is a standard placeholder, which means the first placeholder in the screen. In this case, I guess, JLR wanted to display "Infotainment-Software:", and then the version number of it (the dynamic value). There is probably a bug , and the system was not able to replace the "%1" by the version number of it.
That makes sense. Mine doesn’t have that “%1” part.
Thanks for the explanation. I just checked several language settings (French, Dutch Norwegian, Dansk, and others): This "%1" only shows up if the Infotainment system language is set to German.
2019 I-Pace S, Firenze Red, Light Oyster Interieur, Acitve Air suspension, 18" Diamond turned Wheels.
Infotainment-Software: S20A_20.16.5-536345| Telematics: 17.2 | 40.000 KM of happy I-Pace driving since March 14th, 2019

tomdibom
Posts: 4
Joined: Sat May 04, 2019 10:18 pm
Location: 92245

Re: S20A_20.07.5-507626 SOTA

Post by tomdibom » Fri May 22, 2020 9:22 am

Thank you very much - it is helpfilly. Stay healty forum members...... Thomas
I-Pace blue

Jelle v/d Meer
Posts: 1243
Joined: Sat Apr 28, 2018 7:43 pm
Location: Tilburg / Netherlands

Re: S20A_20.07.5-507626 SOTA

Post by Jelle v/d Meer » Fri May 22, 2020 10:03 am

So England, Scotland, Germany, Belgium, Luxembourg, Romania all have the S20A update - yet in the Netherlands still no S20A available :( .
This despite NL having the 2nd biggest fleet of I-paces.
I-pace S + HUD + Drive Pack + Light Oyster Sport Seats + Tailgate I Ceasium Blue | 18" wheels
Infotainment 19C + Telematics 18.2 | ODO 48.596km | 2020 Efficiency 211watt/km.

User avatar
ELray
Posts: 648
Joined: Sat Dec 29, 2018 2:02 am
Location: Norway

Re: S20A_20.07.5-507626 SOTA

Post by ELray » Fri May 22, 2020 10:20 am

Jelle v/d Meer wrote:
Fri May 22, 2020 10:03 am
So England, Scotland, Germany, Belgium, Luxembourg, Romania all have the S20A update - yet in the Netherlands still no S20A available :( .
This despite NL having the 2nd biggest fleet of I-paces.
Yeah, they are very conservative with the roll out.
It’s same in Norway, however, I have lowered my expectations when it comes to Software enhancements OTA with Jaguar...
🇳🇴 Norway
:arrow: I-Pace S Edition X590 (19MY)
:arrow: Build date: 1 Feb 2019 | Delivered: 15 March 2019
⚙️ H264: 06.01.20
⚙️ Telematics: 16.2
⚙️ InControl(updOTA:27.05.20): S20A_20.16.5-536345
⚙️ BECS: Unknown
⚙️ Maps(upd:08.05.20): 08.030.0107.0158

Adrian iPace
Posts: 91
Joined: Thu Jan 10, 2019 12:45 pm
Location: Romania

Re: S20A_20.07.5-507626 SOTA

Post by Adrian iPace » Fri May 22, 2020 10:39 am

Jelle v/d Meer wrote:
Fri May 22, 2020 10:03 am
So England, Scotland, Germany, Belgium, Luxembourg, Romania all have the S20A update - yet in the Netherlands still no S20A available :( .
This despite NL having the 2nd biggest fleet of I-paces.
Not in Romania till now.
I have de first edition of S20A 20.07.05 pushed by dealer in March, not the newest S20A 20.16.5 by SOTA.
Corris Grey, 20", X590 2020

Jelle v/d Meer
Posts: 1243
Joined: Sat Apr 28, 2018 7:43 pm
Location: Tilburg / Netherlands

Re: S20A_20.07.5-507626 SOTA

Post by Jelle v/d Meer » Fri May 22, 2020 10:51 am

Adrian iPace wrote:
Fri May 22, 2020 10:39 am
Jelle v/d Meer wrote:
Fri May 22, 2020 10:03 am
So England, Scotland, Germany, Belgium, Luxembourg, Romania all have the S20A update - yet in the Netherlands still no S20A available :( .
This despite NL having the 2nd biggest fleet of I-paces.
Not in Romania till now.
I have de first edition of S20A 20.07.05 pushed by dealer in March, not the newest S20A 20.16.5 by SOTA.
Well in NL we do not have any S20A yet, I am still on 19C and my car had a full software update at the dealer mid April :( :o
I-pace S + HUD + Drive Pack + Light Oyster Sport Seats + Tailgate I Ceasium Blue | 18" wheels
Infotainment 19C + Telematics 18.2 | ODO 48.596km | 2020 Efficiency 211watt/km.

Post Reply