Problems with 7kw Polar Plus charging

All Jaguar I-Pace related discussions
Post Reply
JonB
Posts: 76
Joined: Sat Nov 10, 2018 11:59 pm
Location: London

Problems with 7kw Polar Plus charging

Post by JonB » Sun Feb 10, 2019 10:35 pm

I live in central London and have no possibility of having my own home charger here. However outside of my front door is an Ubitricity 5.5kw lamp-post charger and I have subscribed for one of their specialist metered cables which works just fine. However, around the corner is a Polar Plus 7kw charge post with 2 chargers and since I also have Polar Plus membership I would very much like to be able to use it too, along with other Polar Plus units around the country. For some reason though I am having terrible difficulties with the Polar Plus unit although it is used by a wide variety of EV's every day and I don't see any of them having any problems at all. However, every time I try to hook up to it it either doesn't get started at all or it works for a few minutes with about 0.5kwh of charge and then stops. If I start all over again then nothing happens and it just flashes green and blue indicating it isn't charging. When I phone Polar Plus they say they can't do anything about it and given that no one else seems to have any trouble with it with their ev's I am wondering if it is an iPace problem. I had no problems with a Polar Plus 50kw unit in Hertfordshire a few weeks ago but it is making me very nervous about recharging if and when I am out and about and want to hook up to other 7kw Polar Plus units.

So, has anyone else had any experience using Polar Plus and if so, has it worked fine or are you too having problems?

Thanks in advance


nipri
Posts: 241
Joined: Tue Sep 11, 2018 2:02 pm
Location: United Kingdom

Re: Problems with 7kw Polar Plus charging

Post by nipri » Mon Feb 11, 2019 2:12 pm

Hi JonB,
I use Polar Plus regularly from 7kw -50kw & have had no issues at all.
Have found them so reliable from London to Birmingham to Bath.
Thanks.


Pacesetter
Posts: 100
Joined: Sat Nov 03, 2018 10:55 pm
Location: United Kingdom

Re: Problems with 7kw Polar Plus charging

Post by Pacesetter » Mon Feb 11, 2019 5:57 pm

I've only used a couple of times but have had no issues.
First Edition, Corris Grey


Post Reply

Return to “Main Jaguar I-Pace chat”