Page 1 of 4

Charging in UK/Scotland on 50kw

Posted: Thu Feb 07, 2019 4:33 pm
by batteries_included
As im still waiting for home charger to be fitted ( apparently North East Scotland is the back of beyond).

I've been using public chargers for over a month (Tried at least 10 locations).

This means I have spent along time getting cold and wet in car parks playing charge lottery - is the machine working, is the connector working, is it going to recognise the car ? is it going to start charging then stop within a minute? On the phone to Chargeyourcar only to get cut off or getting through to be told "sorry machines out of order" or "its your car" . End up leaving it overnight on AC as it the only guaranteed way to get it charged.

Anyone else having the same problems as dealer tells me no else is?

Re: Charging in UK/Scotland on 50kw

Posted: Thu Feb 07, 2019 9:56 pm
by Baikar
I’m about to drive my car from Ireland to Scotland and end up in London this weekend so I’m praying it will be trouble free.

Re: Charging in UK/Scotland on 50kw

Posted: Fri Feb 08, 2019 9:49 am
by Goshdarnit
I always find Instavolt works perfectly. The one and only time I tried a Chargeplace Scotland one, it didn’t work. Of course it was cold and raining and I was on the phone to the helpline for about 20 minutes trying various things before he decided it was clearly faulty and took it out of service! You get what you pay for I suppose...

Re: Charging in UK/Scotland on 50kw

Posted: Fri Feb 08, 2019 10:42 am
by JonB
I am having trouble with a Polar 7kw charger round the corner from where I live in central London. The charge point is used almost all the time during the day by a variety of vehicles, all apparently without a problem. However when I have cabled up my iPace to the charger it worked absolutely fine on the first occasion but cut out after a few minutes the second time I tried, and then failed to work after numerous attempts to reconnect as well as calls to the Polar service centre in the freezing cold in the middle of the night. Ditto the third occasion I tried where it didn't work at all. I am pretty certain it is the vehicle not the charger that is the problem since everyone else with their BMW's, Nissan's, Tesla's and the rest seem to have no problem at all. On the other hand I have no problem with the 5.5kw Ubitricity lamp post charger outside my house, and shortly after I got the car I had a successful charge off a 50kw Polar charger in Hertfordshire. It also charges fine off my own 7kw home charger in Suffolk. All a bit of a mystery really.

Re: Charging in UK/Scotland on 50kw

Posted: Sat Feb 09, 2019 3:18 pm
by GreyIpace
I'm in the Scottish central belt. If you look at the CYC map nearly 80% of the rapid CCS 50kw chargers are in an "unknown" state. Raised the fact that my local CCS 50kw charger was not working with CYC many weeks ago. It's still not working.
Have tried six of the other rapid CCS chargers in the central belt and they are in the same state - not working. The connector looks ok, the charger starts the handshake, indicates it's charging, then kicks it off after about 5 minutes.
Must have tried six different Instavolt chargers and they all worked ok.
Firstly I think that the machines on the ChargePlace network are not very good machines. or there is a problem with the CCS software as Leaf's never seem to have a problem. Secondly, if you look at ownership and management of them I suggest they are hardly motivated to fix them with the BP Polar network expansion.
The Charge Place Scotland network as far as CCS is concerned is a bit of a joke. They don't seem to care either.

Re: Charging in UK/Scotland on 50kw

Posted: Sat Feb 09, 2019 3:25 pm
by Goshdarnit
I’ve only ever tried that one CPS charger that one time. Never went back to see if they’ve fixed it. But very impressed with instavolt. A lot of them are on free bend at the moment as well, but they’ll be quite expensive when they start charging. However as most of my charging will be at home I don’t mind paying through the nose for a decent service on the odd occasion that I do need to charge away from home.

Re: Charging in UK/Scotland on 50kw

Posted: Mon Feb 11, 2019 9:54 am
by batteries_included
GreyIpace wrote:
Sat Feb 09, 2019 3:18 pm
I'm in the Scottish central belt. If you look at the CYC map nearly 80% of the rapid CCS 50kw chargers are in an "unknown" state. Raised the fact that my local CCS 50kw charger was not working with CYC many weeks ago. It's still not working.
Have tried six of the other rapid CCS chargers in the central belt and they are in the same state - not working. The connector looks ok, the charger starts the handshake, indicates it's charging, then kicks it off after about 5 minutes.
Must have tried six different Instavolt chargers and they all worked ok.
Firstly I think that the machines on the ChargePlace network are not very good machines. or there is a problem with the CCS software as Leaf's never seem to have a problem. Secondly, if you look at ownership and management of them I suggest they are hardly motivated to fix them with the BP Polar network expansion.
The Charge Place Scotland network as far as CCS is concerned is a bit of a joke. They don't seem to care either.
I totally agree Chargeplace Scotland is a complete joke - I have asked by email several times why most of the CCS 50 KW chargers are "unknown" status but have not had a reply.

It also seems the Ecotricty machines have a real problem with the I-Pace, wont connect or connect and then stop - are real pain and again no seems to care.

In my experience as well only Instavolt work without a problem.

Re: Charging in UK/Scotland on 50kw

Posted: Mon Feb 11, 2019 10:17 am
by Bluealeurone
Yes I have many problems with 50kw chargers. Tried 3 different chargers in Broughty Ferry. None worked. Went to Carnoustie charger it worked for a little while then kicked me off. I am going to speak to the dealer about this and the fact my range on 100% charge can be as low as 196 miles.

Re: Charging in UK/Scotland on 50kw

Posted: Mon Feb 11, 2019 12:23 pm
by electricdriver
Disappointing ... thought I’d been super organised in buying a Charge Place Scotland card for my long trip next week.

Does anyone know ... if the status on the CPS website says “unknown” (and most of the CCS points do), does that mean that the point is definitely unavailable or is it still worth trying?

Appreciate any feedback! Thanks all.

Re: Charging in UK/Scotland on 50kw

Posted: Mon Feb 11, 2019 2:43 pm
by batteries_included
electricdriver wrote:
Mon Feb 11, 2019 12:23 pm
Disappointing ... thought I’d been super organised in buying a Charge Place Scotland card for my long trip next week.

Does anyone know ... if the status on the CPS website says “unknown” (and most of the CCS points do), does that mean that the point is definitely unavailable or is it still worth trying?

Appreciate any feedback! Thanks all.
As I said earlier CPS refuse to answer or explain why so many shown "unknown" . If they are being used they show as no longer available, however "unknown is a lottery" as is "available" unfortunately - for example, two machines near me show as available however the CCS connector's are broken (one for over two months but nothing done as the Chademo works.

Good Luck with your trip, I've already binned planned trip to Wales in April, will pay for petrol and the comfort of knowing I can make the trip in daylight!